AnsweredAssumed Answered

PDI 8.1 not starting

Question asked by Zachary Pappas on Sep 13, 2018
Latest reply on Sep 21, 2018 by Alain Debecker

Hello All,

I have PDI 8.1 downloaded and installed on my computer (community edition and trial enterprise edition).  It worked perfectly yesterday, and today when I try to start it, the command prompt pops up and closes as normal, then the PDI window shows up, and after kettle will open and close immediately.  I tried clearing the cache in the Karaf folder and in the .kettle folder, but still no luck.  I also modified the spoon.bat file to PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx1024m", but it did not help either.  I ran the spoon debug and it gives the following error:

ERROR (version, build from 2018-04-30 09.42.24 by buildguy) : Error starting Spoon shell

General - ERROR (version, build from 2018-04-30 09.42.24 by buildguy) : java.lang.NullPointerException

General -     at org.pentaho.di.ui.util.EnvironmentUtils.getUserAgent(

General -     at org.pentaho.di.ui.util.EnvironmentUtils.isUnsupportedBrowserEnvironment(

General -     at org.pentaho.di.ui.spoon.Spoon.checkEnvironment(

General -     at org.pentaho.di.ui.spoon.Spoon.start(

General -     at org.pentaho.di.ui.spoon.Spoon.main(

General -     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

General -     at sun.reflect.NativeMethodAccessorImpl.invoke(

General -     at sun.reflect.DelegatingMethodAccessorImpl.invoke(

General -     at java.lang.reflect.Method.invoke(

General -     at org.pentaho.commons.launcher.Launcher.main(


Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0


Any suggestions?


Thank you,