AnsweredAssumed Answered

Pentaho Kitchen randomly get stuck while connecting to SQL-Server

Question asked by Alessandro Soggia on Jul 11, 2018
Latest reply on Jul 12, 2018 by Dan Keeley

I've created an ETL job that connects to SQL Server in order  to run some transformation.

I'm using the following versions

Windows Server 2012 R2

SQL Server 2016



sqljdbc_6.0.8112.100_enu (Using windows integrated authentication)


The ETL runs every hour, the problem is that it randomly get stuck while trying to connect to the database.

I've removed all the steps and left only one step of type "Check DB" with a timeou of 5s.


When the problem occurs kitchen just gets stuck, and the timeout never triggers.

I've also tried to enable logging with debug level but nothing gets logged, just the process gets freezed.

This happens randomly, I've tried with three different servers, pentaho 8, pentaho 8.1, integrated auth and SQL authentication with no luck.


Any idea how to solve it?



Thank you very much